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Converting Legacy Scheduled 
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 Conversion Overview 
 Creating the View 
 Windows Task Scheduler 

Command 
 

In SiteAudit 3.x, scheduled reports were XML documents.  However, a parameter in the 
Windows Task Manager command was used to specify a stylesheet that could transform the 
report into HTML, CSV, TXT or other types of documents.  If a manager wanted to see the data 
in the report aggregated or formatted differently, it required a new stylesheet or the 
modification of one of the supplied samples.  
 
In SiteAudit 4.0, all reports are created from a view; therefore, users have a minimum of 
fourteen different types of reports that can be scheduled.  The six scheduled reports that were 
available in SiteAudit 3.x can be derived from one of the views in SiteAudit 4.0.  There are many 
ways to organize and filter data in a view and it is also possible to include many styling features 
to create numerous types of reports.  Another new feature in SiteAudit 4.0 is the ability to 
generate scheduled reports in PDF, RTF, and XLS formats. 
 
Creating and modifying scheduled reports in SiteAudit 4.0 is easy and does not require 
stylesheets.  However, the use of stylesheets is still supported and the rest of this document 
explains how to reuse your stylesheets and filter documents to recreate the same reports that 
were created with earlier versions of SiteAudit.  
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Conversion Overview 

SiteAudit 4.0 allows you to reuse the custom stylesheets and filter documents you had created 
for your SiteAudit 3.x scheduled reports to reproduce the same scheduled reports.  However, in 
many cases, it is better to start from scratch by creating a scheduled report from a SiteAudit 
view as described in the knowledgebase article, Scheduling Reports.   
 
The following is an overview of the steps required to recreate a legacy scheduled report.  The 
remainder of this document describes each of these steps. 
 

 Open a scheduled report template  

 Modify the XML file format options 

 Configure the scheduled report delivery options 

 Save the view 

 Configure the Windows Task Scheduler 
 
 

Open a Scheduled Report Template 

Since all reports are created from an existing SiteAudit view, the first thing one must do to 
support a legacy scheduled report is to recreate a view that contains the information that had 
existed in the legacy report.  This requires that the view display all of the columns of data that 
exist in the scheduled report.  Users may need to add or remove columns to a view so that all 
the appropriate data appears in the scheduled report.  Since users may not know which 
columns to display in a view, sample view file templates have been created for all legacy 
scheduled reports.  The templates can be found in the SiteAudit installation directory, 
Netaphor/SiteAudit/Samples/en/ScheduledReportTemplates.   
 
Suppose you want to recreate the AssessmentDetails scheduled report.  Start by opening the 
AssessmentDetails.view file via the SiteAudit Viewer File > Open menu.  Navigate to the 
SiteAudit installation folder and choose the AssessmentDetails.view from the 
Netaphor/SiteAudit/Samples/en/ScheduledReportTemplates folder.  Taking this action opens 
the view necessary to generate the scheduled report.   
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Scheduled Report Templates 

The following templates are installed with SiteAudit 4.0 to facilitate the creation of legacy 
scheduled reports.  Legacy scheduled reports are those reports that were created in SiteAudit 
3.x using custom stylesheets or filter documents.  Table 1 indicates which templates are 
associated with legacy scheduled reports. 
 
Table 1 – Scheduled Report Template Map 

SiteAudit 3.x Scheduled Report Template Name 

Assessment Details AssessmentDetails.view 

Inventory Inventory.view 

Low Consumables LowConsumables.view 

Low Consumables by Type LowConsumablesByType.view 

SLA Analysis SLAAnalysis.view 

Usage and Counts Usage_SampleCSV.view 

 
 

Quick Guide to Using a Scheduled Report Template 

Suppose you had created a stylesheet to display the usage and count data, and instead of using 
the new scheduled report features of SiteAudit 4.0, you prefer to continue using the stylesheet.  
The following steps explain what you must do to schedule a similar report using SiteAudit 4.0. 
 

 Select the File > Open menu item and open the UsageAndCounts_XML.view template 
from the installation folder, which is typically 
C:\ProgramFiles\Netaphor\SiteAudit\Samples\en\ScheduledReportTemplates. 

 Confirm or modify the XML format options 

 Configure the email and archival delivery options 

 Save the view 

 Update the Windows Task Scheduler command 
 
When the Task Scheduler command is executed, the report will be emailed and archived as 
specified.  
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Modify the XML File Format Options 

Users must reference their stylesheet and filter document using the File Format Options dialog, 
which can be opened by selecting the Reports > File Format Options menu item and selecting 
the XML format options tab as shown in Figure 1. 
 

XML Format Options 

SiteAudit 4.0 supports reports in the XML format and allows for specifying an XSL stylesheet to 
transform and style the report.  This allows users to create specialized reports and supplies 
backward compatibility for scheduled reports produced with SiteAudit 3.x.  The XML format 
options include the option to specify a filter document which filters data from the report prior 
to applying the stylesheet.  Again, this is for backward compatibility as filtered documents are 
no longer needed in SiteAudit 4.0.  Users can filter data in the view using the standard filter 
control that has always been a part of SiteAudit. 
 
Figure 1 – XML File Format Options 

 

Filter Devices 

For users who want to create reports using a filter document that describes what to include in 
the report, check the Filter devices checkbox and enter the filter document name and path in 
the Filter specification. For more information on filtering report content, refer to the SiteAudit 
KB article, Customizing the ReportFilters Document. 
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Use Stylesheet for Transformation 

The XML format options provide a way for users to specify an XSL stylesheet to transform the 
XML report content into a preferred style.  This option is used to create reports that are not 
possible using an existing view.  For instance, some users may want to transform data into a 
format that can be input into another program or database and may require special formatting. 
In this case, a custom stylesheet would be appropriate.  To use an XSL stylesheet to transform 
the XML report, select the Use stylesheet for transformation checkbox and enter the name and 
path of the stylesheet in the Stylesheet textbox. 
 

Omit XML Declaration 

The Omit XML declaration while transforming option removes the XML declaration from the 
XML report and supports backward compatibility for scheduled reports created with SiteAudit 
versions prior to 4.0.  This option is useful when the declaration is not needed in the XML report.   
 

Output file extension 

The Output file extension is the extension that will be applied to the report when it is created.  
By default the report extension is XML; however, if your stylesheet transforms the report into 
another format such as CSV, TXT, HTML, et cetera, then enter the desired extension in the 
Output file extension textbox. 
 
 

Configure the Scheduled Report Delivery Options 

It is necessary to configure the email and archival delivery options for your scheduled report.  
Open the Delivery Options dialog by selecting the Reports > Delivery Options menu item. 
 
Figure 2 – Deliver Options Dialog  
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The Delivery Options dialog contains a tab for configuring email options and one for configuring 
the desired archival options.  The following sections explain how to configure these options. 

Scheduling Email Delivery Options 

SiteAudit reports can be emailed to specified recipients whenever that Windows Task Scheduler 
task is executed.  Reports are included as attachments to an email.  This section describes how 
to configure the email options. 
 
To enable email delivery of a report, check the Enable email delivery checkbox and configure 
the rest of the email options.  If the report should not be emailed, then uncheck this checkbox. 
 
Figure 3 – Email Delivery Options 

 

Format 

Reports can be emailed in one of the following formats: PDF, XML, HTML, RTF, XLS, or CSV.  If 
an XSL stylesheet or filter document is specified in the File Format Options dialog, then this 
option MUST be set to XML.  Otherwise, it is safe to choose the desired format option. In 
SiteAudit 3.x, all reports were XML documents and required stylesheets to stylize or convert the 
report to a desired format.  This is no longer necessary as SiteAudit 4.0 scheduled reports can 
be delivered in any of the supported formats.  
 

Enable File Compression 

Check the Enable gzip compression checkbox to compress the report.  When this option is 
selected, a report is compressed when it is attached to an email.  The report file extension will 
be gz and users must uncompress the file to view the report.  Compressing a report is useful 
when the size of the report is very large.  The size of a report can be an issue since some routers 
do not allow email attachments larger than 5MB.   
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Attachment Name 

All scheduled reports are delivered as email attachments.  Enter a name for the report 
attachment in the Attachment name textbox.  For example, suppose the attachment name is 
ABC and the desired report format selected was PDF.  The email attachment and/or archived 
file name will be ABC.pdf.  If gzip compression is enabled, the report file name would be ABC.gz. 
 

Deliver To 

Enter the email recipients in the Deliver to textbox.  Each email recipient addresses must be 
separated by a comma or semi-colon.   
 

Sender’s Email Address 

Enter the address of the email sender.  This address will appear in the FROM portion of the 
delivered email and can be any valid email address.  This field must contain a valid email 
address in order for SiteAudit to email a scheduled report. 
 

Display Name 

Enter the sender’s display name in the Display name textbox. For example, suppose a user 
enters the sender’s email address as abc.com and enters the display name, siteaudit.  The email 
will appear to have come from siteaudit [abc.com]. 
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Mail Server Configuration 

In order to send email, the mail server must be configured.  Click the Mail server configuration 
button to open the Mail Server Configuration dialog.  Enter the server information and 
credentials if required.  To confirm that the mail server is configured properly, enter data into 
the Test email configuration section and click the Send test message button.  Confirm that the 
test email was delivered. 
 
Figure 4 – Mail Server Configuration Dialog 

 

 

Scheduling Archive Delivery Options 

SiteAudit reports can be archived to a storage location periodically using the Windows Task 
Scheduler.  When the Task Scheduler task is invoked, SiteAudit generates and archives the 
report as defined in the Mail Server Configuration dialog. 
 
To allow reports to be archived, check the Enable archival checkbox.  If this checkbox is not 
selected, reports will not be archived. 
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Figure 5 – Archival Delivery Options 

 
 
 

Format 

Reports can be archived in one of the following formats: PDF, XML, HTML, RTF, XLS, or CSV.  
Select the desired file format for the report.  For scheduled reports that use stylesheets to 
transform the report, this field MUST be set to XML. 
 

Enable File Compression 

Check the Enable gzip compression checkbox to compress the report.  When this option is 
selected, a report is compressed when it is archived.  The report file extension will be gzip and 
users must uncompress the file to view the report.  Compressing a report is useful when the 
size of the report is very large.   
 

Archival Folder 

 Enter or select the folder where you want schedule reports to be archived 
 

Archival Template 

The archival template allows users to define the file name of their report and include a 
date/time stamp.  Each time a report is generated the file name will be appended with the 
current date and time.  Suppose a Windows Task Scheduler task has been created to archive a 
consumable report once a month.   
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Example 
Suppose a user entered an archival template name as: Consumables<yyyyMMdd> and the 
report was generated on January 1, 2010; February 1, 2010; March 1, 2010.  The archived 
reports will be named, 

 Consumables20100101.html 

 Consumables20100201.html 

 Consumables20100301.html 
 
The file extension is determined by the file type that was specified in the Delivery Options 
dialog. 
 
 

Save the view 

A view must be saved before it can be scheduled for email or archival delivery.  Save a view by 
selecting the File > Save or File > Save As menu item. 

  

 

Configure the Windows Task Scheduler 

Once a view has been configured and saved, it can be scheduled using the Windows Task 
Scheduler. 
 
Launch the Windows Task Scheduler by selecting the Tools > Task Scheduler menu item.  Create 
a new task to run the report. 
 
SiteAudit 4.0 requires only a single argument to run the report.  This argument is the path and 
name of the view file that was saved.  
 
The command to run a SiteAudit scheduled report consists of two parts: 

1. The SiteAudit program that generates and delivers the report 
2. The path and name of the view from which the report is created. 

 
The SiteAudit program that generates and delivers the SiteAudit report, is located in the root installation 
folder and is named, SiteAuditScheduledReports.exe and is typically installed in the following location:  
C:\Program Files\Netaphor\SiteAudit. 
 
Example Task Scheduler command used to run a SiteAudit report. 
C:\Program Files\Netaphor\SiteAudit \SiteAuditScheduledReport.exe   C:\MyScheduledReport.view  

  
  
  
  

 


