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SiteAudit supports data collection for many different printer models. However, cases may
arise where some data is not collected for a particular printer. This article explains how to
collect data necessary to add support for objects not monitored or collected by SiteAudit.

Requesting Data for Inclusion in SiteAudit

SiteAudit collects data from many different manufacturer printers; however, the printer universe is
diverse and it is not possible to know all of the various printer models and the implementation of their
respective Management Information Bases (MIBs). A MIB defines which printer objects can be accessed
by SiteAudit and other SNMP tools. Although there is a standard printer MIB that defines the objects
that all printers should support, each vendor is free to implement their MIBs however they choose.

SiteAudit can discover SNMP-supported printers but may not monitor and collect data from all
interested objects. When such a printer is detected, service personnel can use diagnostic tools to collect
the desired data and forward it to Netaphor technical support for inclusion in the product. The
remainder of this document explains the process for adding additional support for printer objects.

Example: SiteAudit Consumables Data Collection

Suppose that SiteAudit discovers a particular model of HP printer but does not collect nor display the
toner coverage levels (Figure 1). However, when the device web pages are examined, the coverage
levels are present (Figure 2). Since these objects exist on the Web page, there is a good chance that
SiteAudit can monitor the objects. (Figure 3) shows the consumables data after the coverage objects
have been monitored by SiteAudit.
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Figure 1. No coverage data has been collected for the toner cartridges

Identification | Counts Consumables | Inputs " Cukputs | Print Servers " Starage " Asset Information |

Description Serial # Installed Coverage

Cyan Print Cartridge HP C97214A Toner cartridge 64515

6. 0%
Magenta Print Cartridge HP C97234 Taoner cartridge 210405 6/29/2009 96.0%
Yellaw Print Carkridge HP C97224 Toner cartridge 57567 96.0%
Image Transfer Kit HP Q36754 Transfer unit 98.2%
Image Fuser kit HP 110%-Q36764, 2200-036774 Fuser 97.0%

Figure 2. Device Web page shows values for Historical Printer Coverage

Histarical Printer 2

Black 4.0%
Chyan 1.9%
Wagenta 1.5%
Yellow 2.2%

Figure 3. Device Details after coverage data collection is added to SiteAudit

_Consumables- | Inputs || Cukputs || Print Servers ” Storage || Asset Information |

Description Serial # Installed
Black Prink Cartridge HP S Toner cartridge 150044 =
Cyan Print Cartridge HP C97214 Taner cartridge 54515 1.9%  96.0%
IMagenta Print Cartridge HP C97234 Toner cartridge 210405 B/29/2009 1.5% 96.0%
ellow Prink Cartridge HP C97224 Taner cartridge 57567 2.2%  96.0%
Image Transfer kit HP Q36754 TransFer unik 96.2%
Image Fuser Kit HP 110Y-Q36764, 2200-036774 Fuser a7.0%
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Requesting Device Support

When a device is discovered for which certain objects are not collected by SiteAudit, service personnel
can forward a request to include support to Netaphor Support. The request should include specific
information that is detailed in the remainder of this document. Netaphor will evaluate and include
support for the requested objects whenever possible.

Please execute the following procedure prior to requesting device support:

1. Confirm that the device can be reached on the network
a. Pingthe device. This is a quick diagnostic to determine if the device is available on the
network.
i Open the DOS command-line utility
ii. Enter the device address after the ping command: ping <ipaddress>
If replies are received from the device, then it has a valid network connection
Example: ping 10.0.0.86

C:“\>ping 18.8.0_86
Pinging 1A.A_A_86 with 32 bhytes of data:

Heply from 18.8.8.86: hytes=32 time=1ims TTL=64
Heply from 18.8.8.86: hyte 2 time=1 T
Heply from 18.8.8.86: hyte 2 time=1

Heply from 18.8.8.86: hyte 2 time=1ms TTL=6h4

Ping statistics for 1A.8.8.86:

Packets: Sent = 4. Received = 4, Lost = B (B% loss).
Aipproximate round trip times in milli-seconds:

Minimum = 1ims. Maximum = 1ms. Average

Czvn>

Note: It may not be possible to ping a device that is not on the local network

2. Confirm that the device can communicate over the SNMP Protocol
a. Use the SiteAudit Device Object Browser to collect device SNMP data
i. Follow the instructions for collecting and saving SNMP data in the section titled,
SiteAudit Object Browser

If the Device Object Browser is unable to collect device data, confirm that the Community name
is identical to the device community name, which is case-sensitive. If it is still not possible to
collect data, consult with your IT department to determine why the device cannot communicate
using SNMP.

© 2009 Netaphor — Confidential CHANNEL PARTNER ONLY Last U
v1.0

Operation Tips — Distribution prohibited, Material Copyright Netaphor Software, Inc. and is provided AS IS




3. Confirm that the printer serves HTML pages. Some printers support both HTML pages and Java
applets on different ports, such as 80 and 8080. It is also possible that the printer can be configured
to serve either a Java applet or HTML pages. Configure the device to serve HTML pages if possible.

4. Use the Fiddler tool to collect and save HTTP data. This step should be performed as soon as
possible after step #2.
a. Follow the instructions for collecting and saving HTTP data in the section titled, Using
Fiddler.

Important! The printer must serve HTML web pages for the Fiddler information to
be useful. If the printer does not serve HTML pages, then please take screenshots of
the objects and values that you want SiteAudit to support.

5. Submit a device support request to support@netaphor.com and include the following
information
a. The manufacture name and model of the printer device

b. The device IP address

c. The names of the objects that you want SiteAudit to support such as, Total
Count, Fax, device serial number, toner level, etc.

d. The file saved using the SiteAudit Device Object Browser in step 2

e. The file saved using Fiddler is step 4 (or screenshots of the objects and values)
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SiteAudit Object Browser

How to Use the SiteAudit Object Browser

The SiteAudit Object Browser is a diagnostic tool for communicating with devices using the SNMP
protocol. SiteAudit must be able to communicate with a printer using SNMP in order for it to monitor
and collect device data. The Object Browser tool can be used to confirm that a device can communicate
over SNMP. Furthermore, the tool can be used to collect SNMP data from a device, which can then be
analyzed by Netaphor Technical Support to determine which objects can be supported in SiteAudit. The
instructions below describe how to use the Object Browser tool.

e Open the SiteAudit Viewer

» Select the Inventory view (or any view that contains the device to browse using the diagnostic
tool)

e Locate and select the device to test

e Launch the Device Object Browser. From the Tools menu, select Diagnostics > Browse objects...

a Netaphor SiteAudit™

File  Wiew  Setup  Reports | Tools | Help

|_'L o ‘ E Lj L:ﬁ o A Stop Monitaring I v| |
Scheduled Tasks. ..
Inventory b by that colu
Import. ..
[= | METAPHOR SOFTWARE, IMC, - - - Serial #
pe— Diagrostics 3 | Browse ohijects, .. ‘L
Adrninistration 1¥ZB5S
Cuskomer Service Refresh FS | S0L Query... T

|| €2

& Engineering |Browse device Dbjectsl
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9 pevice Object Browser

browsed can be saved into a file for submission to Metaphor Technical Support, This tool is for meant for conducting diagnastics, and

i Browse the device using the SHMP protocol, Specfy the 1P address and the community name as appropriate. The objects that are:
’ musk be used with caution,

IP address:  (10,0.0.86 Cormmunity: Start with: [1.3.6.1 | [ Browse ]

Drag a column header here to group by that column

1361.21.1.1.0 OctetString HPF ETHERMET MULTI-ENYIROMNMENT, ROM R 22,01, JETDIRECT, JD9S, EEPROM R.25.57, CIDA... |
136121120 QID 1.36.1.4.1.11.2.3.9.1 =
1.3.61.21.1.3.0 TimeTicks 1.053:26:40.2

1.361.21.1.4.0 OctetString

1.3.61.21.1.50 OQctetString PRTZ99

1.3.61.21.1.6.0 OrctetSkring

1.3.61.21.1.7.0 Integer3z &4

1.3.61.21.21.0 Integer3z 2

t.zel.21.2211.1 Integer3z 3k

1.361.21.221.1.2 Integer3z z

l3e6l.21.22121 Qcketstring HP ETHERMET MULTI-ENYIROMNMENT,ROM R'.22.DI,JETDIR.ECT,JDQS,EEPROM R.25.57
13612122122 Qcketstring HF ETHERMET MULTI-EMNYIROMNMENT, ROM R, 22,01, JETDIRECT, D95, EEFROM . 25,57
136121221351 Integer3z 6

1.361.21.22132 Integer3z 24

.| - A}_

['Savetofile... ]L Close ﬂ

» Confirm that the device IP address and the Community name are correct

Click the Browse button to start the data collection
e Once the data collection completes, the Save to file... button will activate

Click the Save to file... button and save the results

© 2009 Netaphor — Confidential CHANNEL PARTNER ONLY Last Updated: 7/02(200¢
Operation Tips — Distribution prohibited, Material Copyright Netaphor Software, Inc. and is provided AS IS




Using Fiddler

Fiddler Debugging Proxy

Fiddler is a third party tool that is used to collect HTTP traffic when users visit Web pages. Fiddler
should be configured automatically for use with Internet Explorer, so it is recommended that this
browser be used when collecting data. If another browser, such as Firefox, is used and Fiddler cannot
capture data, then it will be necessary to configure the browser proxy to use port 8888.

Where to get Fiddler
The Fiddler tool can be downloaded from the Fiddler Website: http://www.fiddler2.com

How to collect data
Fiddler listens for HTTP traffic on port 8888 by default and collects data for each Web page that the user
visits. This section describes how to use Fiddler to capture HTTP traffic.

1. Start the Fiddler application

Web St K I‘ ﬁ Request Builder || |l Filters || = Timelirie || LJ Gallery|
# Result | Protocol - Hosh LfRL (&) Shatistics ‘ B session Inspector ” # AutoResponder |
Elo 200 HTTR v Fiddler2.com  ffiddler2/updatecheck, as Request count: L
EyTes Seft: 211
Eytes Receiwved: &40

I»

ACTUAL PERFORMANCE

Requests started at:  14:13:06:5268
Responses completed at: 14:13:07:2143
Total Sequence Cime: 00:00:00.6574912
ONWS Lookup time: 13gms

TCP/IP Connect time: 125ms

RESPONSE CODES

HTTP/200: 1

RESPONSE BYTES (hy CORTENT-Type)
~headers: 229
text/plain: 411

ESTiMA.TED \MjRLDWID'E FERFORMANCE
The following are WERY rough est1mates of down'load
times when hitting serwvers based in wWa, USA

US West Coast (Modem - 6KB/sec)
round trip cost: 0.10s
Elapsed Time: ‘0,105

Japan / MWorthern Europe (Maodem)
Round trip cost: 0.15s
Elapsed Time: 0.155

china (Mnﬂemj

<

Show Chart

g Capturing 141 hitkpe v, Fiddler 2, comffiddler2fupdatecheck, aspisBeta=False
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2. Open Internet Explorer and enter the URL of the printer web page, i.e. http://10.0.0.86.
Alternatively, the Web page can be opened from within SiteAudit by right-clicking on a device and
choosing Web Page... from the context menu.

3. Navigate to the various web pages that contain the data that you want to collect. Each time a new
Web page is visited, Fiddler captures the data, which can be seen in the Web sessions frame on the
left. If data is not collect by Fiddler, then it may be necessary to configure your browser to use the
proxy port defined in the Fiddler options. By default, the proxy port 8888 is used.

# Fiddler - HT'TP Debugging Proxy E

File Edit Rules Tools Wiew Help
Veb Sessions S Rec u |:| Filkers :'__—. Timeline | L"ﬂ Gallery |
# Restle]) Rkl LR @ Skatiskics | \;f@ Session Inspector . f AutoResponder |
i i 7 =] -
EID 200 HTTP v, fiddl...  fFiddler2fupdatecheck. asprisBeta=False P e =
| Bytes Sent: 507 st
[#]3 200 HTTP 10,0.0.86  Jhp/devics this LCDispatcher Bytes Received: 200
@4 z00 HTTP 10,0.0.86  fhpjdevice/this L Dispatcher?nav=hp.Config ACTUAL PERFORMANCE
BS 200 HTTP 10.0.0.86  fhpjdevicethis L Dispatcher?nav=hp.Supplies Requests started at: 1412053611385
;_"ﬂs 200 HTTP 10,0.0.86 [hp/device/imagesfMagenta_Toner.gif ?_Eip_lﬂnges CUmp_Ts‘_ZEC_‘ at: églégi_gglgggélgs
otal Sequence time: 10000,
E]? 200 HTTP 10,0.0.86  fhpjdevicethis LCDispatcher?nav=hp.Usage g =
s Z00  HTTP 10.0.0.86  /hp/device/this LCDispatcher?nav=hp.Deviceln| | RESPONSE CODES
HTTR 301: i
RESPONSE BYTES (by Content-Typel
~headers: z0o
ESTIMATED WORLOWIDE FERFORMANCE
The following are WERY rough estimates of
download times when hitting serwers based in
WA, USA,
US west Coast (Modem - GKB/sec] 3
Round trip cost: 0.10s
Elapsed Time: 0.105
Japan f Northern Europe (Modem)
Round trip cost: 0.155
Elapsed Time: 0.155
China (Modem)
Round trip Cost: 0,455
b3 3 Elapsed Time: 0.455 v|
Show Chart
;\, e Capturing 118 http:fH10.0.0.86]
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Saving Fiddler Sessions
Once data for each desired Web page has been captured, save the results.

1. Select all of the sessions in the Web Sessions window. This can be accomplished by pressing CTRL+A
or choosing Select All from the Edit menu.

2. Select Save > Sessions > In Archive Zip from the File menu and then choose the name and location
where the file is saved.

# Fiddler - HTTP Debugging Proxy
=8 Edit Rules Tools Wiew Help

b Web Sessions [E=
Host | LURL

v Capture Traffic F12

| ¥ Request Buid Filters || = Ti

@ Skatistics L%& SESS_iD"I.ﬂ-InSpECt;’. ||§_ Auto_Responder |

Load Archive...

Reguest Count: 7 A
EYEES Sent: 3,845 =
Bytes Recejwed: 134,182

as Yisual Studio Web Test...
as Text...

Request [ 3

Response ACTUAL PERFORMANCE

as Text (Headers only)...

Reguests started at: A4:20:36:13585
Responses completed at: 14:20:50:4975
Total Sequence time: 00:00:14.35531655
TCRAIFP Connect time: 15ms
! RESPONSE CODES.
¥ HTTF/201: 1

@0 sz wTTe t-bore | Sl -

@ s HTe t-bone | :

@2 sz WP bbne | e e e e
image/ i T 270
~headers: 1,468
texthtml 132,444

ESTIMATED WORLDWIDE FERFORMANCE

The following are VERY rough estimates of =l
download times when hitting servers based in
W, USA.

US West Coast (Modem — 6KB/sec)

Round trip cost: 0.705
Elapsed Time: 23.705

Round trip cost: 1.05%

Elapsed Time: 24.055
2
Show Chart
i Capturing 7{12
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